PDA

View Full Version : Trimmer not trimming



bquinn
07-10-2007, 09:54 PM
my thread is not being trimmed 90% of the time on different designs with different threads etc. i've cleaned the entire area, changed the blade and oiled. still no luck. i've searched the archives and there were a couple of posts about the issue and i followed their instructions but still no luck. any ideas? thanks

bruce

THREADS
07-11-2007, 01:44 AM
Hey Bruce,

I am having the same trimming issues on two of my XT's. One machine is down for a week now waiting for a back-ordered knife cable that has a kink in it. That machine, like yours, was failing to trim 90% of the time. The Melco Tech has a suspician that it might also be a bad servo motor.....won't know for sure until the new cable is installed. I also replaced the blade, thoroughly cleaned the area and lubricated....to no avail! Had to get a Tech in here to fix it.

The other machine is failing to trim about 10-20% of the time.....it's real aggravating because I have to babysit the machine while it is sewing.

You should be aware that Melco only covers Tech Travel expenses for the first 90 days of your warranty. So even though your machine is "under warranty" for up to 5 years, your paying hundreds of dollars for a Tech to pay you a visit. My machines are only 4 months old! But they have to be fixed.......so I have to "Pony UP"!

So are you comfortable taking your machine apart and inspecting the knife cables? And can you replace them yourself if you find a problem? Can you identify a faulty servo motor?

If not, your going to have to get a Tech in there.

Mike

bquinn
07-12-2007, 09:29 PM
thanks for the posts brad & mike. called melco tech support and although very courteous, helpful and patient, it looks like i'll have to get a tech in for the push pull cable after all.