Quantcast coming unthreaded after. every.trim.


discussion boards mailing list tips / tricks / forms designs suppliers find a shop marketplace

  main menu

  hoops / hooping
  stock designs

Tips & Tricks
  main menu

Mailing List
  sign up now
my account

Amaya Shops
  locate a shop

  shop for supplies

  official Melco site
  online resources


Help Support This Site:



Results 1 to 4 of 4
  1. #1
    Join Date
    May 2007
    Post Thanks / Like

    coming unthreaded after. every.trim.

    I know, I'm not the first. . . I have looked and looked, read all the posts, tried everything I could think of, and some things that I saw here - nothing is working. Unless I missed something somewhere. . .

    Here's whats been going on: stitches fine (once its going), then trims, and every time the thread comes out of the needle. I thought the trimmer blade must be the issue, so i got a new one, installed it and thought I had it figured out until today. Now it trims just fine, not "pulling" - but the thread up top is coming out of the needle on every trim. Makes a 2 minute simple logo hell..... I even went so far as to remove the trims from the design just so I can get this job done, but.....this is driving me nuts.

    I have checked everything I can think of: rebooted both machine and software, checked settings, tail set to long, checked actifeed - the stitching tells me that it's ok; checked bobbin tension; cleaned everything top to bottom. . .

    any thoughts?
    <a href=\"http://www.jarvismotorsports.com\" target=\"_blank\">www.jarvismotorsports.com</a>

  2. #2
    Join Date
    Aug 2006
    Eureka, California
    Post Thanks / Like
    Do you have your tail length set to long, and have you tried rubbing your work piece with a Bounce dryer sheet? This time of year static can become a thing, and static makes the world miserable. I also hold one for about ten seconds on the red feed roller as it is going along, and rub the faceplace with it when thread starts sticking to it.

  3. #3
    Join Date
    Oct 2006
    Kona, Hawaii
    Post Thanks / Like
    There are something like 15 or so steps that our machines step thru to do a trim. If any one of the steps is out of wack, then it will not trim properly. Thread pulling out of the needle when resuming stitching after a trim is telling you that one of the many steps has screwed up. Which one? I have no idea, but it is one or more of those steps that is not right. And when you find the answer, can you please post the solution?
    Juli in Kona<br />Stitches in Paradise

  4. #4
    Join Date
    Oct 2010
    Etna, CA
    Post Thanks / Like
    What kind of machine do you have? If you search under 'trim' tons of posts come up with all sorts of suggestions depending on your machine and what you are embroidering.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  a Levelbest Network Site - 2013

This site is not owned by or affiliated with Melco or any companies or subsidiaries.